
Using the LabQuest 2 to Collect Data 
To collect data in lab we will use Vernier’s LabQuest 2, a stand-alone device that provides both the 
hardware for collecting data from a variety of probes and the software for displaying and processing 
the data. The information here provides instructions on using the LabQuest 2 within the context of 
Chem 260. 

Brief Overview of LabQuest 2 
The photo below provides a top-side view of the LabQuest 2 and the software’s touch-sensitive 
home screen. Pressing the power button turns on the device: if the device is in its sleep mode, it will 
wake up quickly; if it is fully off, it will take approximately 1-2 minutes for the software to load. 
Pressing and releasing the power button places the device in its sleep mode. To turn the device off, 
press and hold the power button until the shut down screen appears. 

 
At the bottom of every screen is the current time, an icon for accessing the home screen (also avail-
able using the home button located to the right of the screen), an icon showing whether the device is 
connected to Wi-Fi and, if it is, the strength of the signal, and an icon showing the battery’s status. 
The buttons to the right of the screen allow you to start and stop data collection (more on this later), 
to access to the home screen, and to exit from applications, menus, and dialog boxes without taking 
action. 

A variety of applications are available from the home screen, of which the LabQuest App is the 
most important as it controls data collection. Other apps you may find useful are the Periodic Table 
and, inside the Accessories folder, a calculator and a stopwatch. 

The LabQuest 2 has a number of built in sensors for collecting data, two of which—a light sensor 
and a microphone—are shown in the photo above. Other built in sensors include an internal tem-
perature probe for measuring ambient temperature, a GPS sensor for collecting latitude, longitude, 
and altitude readings, and an accelerometer for measuring movement of the device in the x-, y-, and 
z-directions. Of these internal sensors, the internal temperature probe is the only one you will find 
useful in Chem 260. 



The photos below shows two side views of the LabQuest 2. The left photo shows the device’s three 
ports for analog sensors, two ports for digital sensors (which are hidden by a flap that is not shown 
in this photo), and one port for USB sensors; when not otherwise used for a sensor, the USB port 
accommodates a flash drive for saving data (more on this later).  

 
The photo on the right shows the AC power connection used to charge the battery and to run the 
device under AC power. The mini USB port provides a means for connecting the device to a com-
puter, which you can use to transfer data from the LabQuest 2 to your computer, or use to operate 
the device from your computer (more on both topics later). 

Brief Overview of the LabQuest App 
Control of the LabQuest 2 is accomplished using its internal software, which consists of five main 
screens, each providing access to one or more menus. The photo below, for example, shows the 
Graph screen, which includes the File, Graph, and Analyze menus. Note that below the main menus, 
the screen includes a window to display data and a window to display information about the data. 
The five screens are accessed using the icons at the top of the display; from left-to-right, the five 
screens are Meter, Graph, Table, Lab Instructions, and Notes. 

 



The Meter screen is used to set up and to calibrate sensors, and to define the parameters for collect-
ing data. It includes two menus, the File menu and the Sensor menu, and two displays, one showing 
the current readings for each sensor and one showing the current parameters for data collection. 
Further details on using the Meter screen are included later in the section on connecting sensors, 
the section on calibrating sensors, and the section on collecting data. 

The Graph screen displays a live graph of data as it is collected, and tools for displaying and analyz-
ing data already collected and stored. It includes three menus, the File menu, the Graph menu, and 
the Analyze menu, and a window to display data and a window to display information about the 
data. Additional information on using the Graph screen are include later in the section on displaying 
data and the section on analyzing data. 

The Table screen is a single spreadsheet that contains the data for each of your experiments (or 
runs, as they are called here). In addition to the File menu, this screen includes a Table menu that 
allows you to manipulate your data. Further details on using the Table screen are included in the 
section on manipulating data. 

We will not use the remaining two screens, the Lab Instruction screen and the Notes screen, in 
Chem 260. 

Brief Overview of Connecting Sensors 
Begin by navigating to the Meter screen. To connect a sensor, simply plug its connector into an 
available port of the correct type. With the exception of the drop counter (digital) and the spectrom-
eter (USB), all sensors are analog. The LabQuest 2 device will detect the sensor and display a meter 
in the space below the menus. If you do not see a meter, then you must manually add the sensor by 
selecting Sensor Setup from the Sensor menu. Identify the port to which your sensor is connected, 
select the field for that port labeled “No Sensor” to bring up a list of sensors, and choose the ap-
propriate sensor. 

To use one of the device’s internal sensors, such as the internal temperature sensor, select Sensor 
Setup from the Sensor menu and select the appropriate check box. 

Brief Overview of Calibrating Sensors 
A sensor rarely measures directly the thing we are interested in measuring. A thermistor for measur-
ing temperature, for example, measures a change in current that results from a temperature-
dependent change in the thermistor’s resistance, and a pH probe measures a voltage drop across a 
thin glass membrane that results from a difference in the pH of the solutions on each side of the 
membrane. To convert a current to a temperature, or to convert a voltage to a pH value, requires a 
calibration equation. Some sensors, such as the temperature probe, have a built-in calibration equa-
tion; others, such as the pH probe include a built-in calibration equation, but benefit from a more 
careful manual calibration. To perform a manual calibration, navigate to the Meter screen. From the 
Sensor menu, select Calibrate and choose the sensor you wish to calibrate. Instructions for calibrat-
ing the sensor are provided on the device’s screen; additional details on the calibration of our sen-
sors are provided in lab and in Vernier’s instruction manuals (available on-line). 

Brief Overview of Collecting Data 
Begin by navigating to the Meter screen. Select Data Collection from the Sensors menu or touch 
the section on the right-side of the screen that shows the default mode, rate, and duration for data 
collection. 

How data is collected and how it is displayed depends on the mode, which, in turn, depends on the 
sensor(s) and the experiment’s design. Of the options available, we will use three in Chem 260: 



• time based: This mode is used for any experiment in which data is collected and displayed as a 
function of time on the x-axis. The sample rate, the interval between samples, and the duration 
of the experiment are defined by the user. If the rate or duration fields are highlighted in yellow, 
then the selected sampling rate is slower or faster than the sensor’s recommended limits, which 
may distort the data. If the fields are red, then the selected sampling rate is slower or faster than 
the interface can support, or the number of samples exceeds the available storage space; you 
cannot collect data if these fields are red. Under the Advanced settings, oversampling allows for 
the rapid collection of samples near the desired sampling time; these sample are averaged and 
reported as a single value. Oversampling, which is possible when the sampling rate is less than 
10 samples per second, smooths a noisy signal by averaging out the effect of random noise. 

• full spectrum: This mode is used with the spectrometer when measuring absorbance as a func-
tion of wavelength. The sample time (how long the signal is measured) and the wavelength range 
to display are set by the user. Additional options allow for the smoothing of data by averaging 
absorbance readings over several wavelengths, and for signal averaging in which two or more 
spectra are collected and averaged; both of these options help reduce the noise in a spectrum, 
although they must be used with care. 

• drop counting: This mode is used when using the drop counter to titrate a sample. There are no 
user-defined options in this mode. 

To collect data, select the green triangle at the display’s bottom left corner or the collect button 
on the device’s case. During data collection, a live display of the data appears in the Graph screen’s 
main window. When data collection is complete, the software will adjust the x-axis and y-axis scales 
to display fully the data. To stop data collection before the end of the experiment’s duration, select 
the green square at the display’s bottom left corner or the collect button on the device’s case. 

To store data from a run, select Store Run from the Graph menu or select the file cabinet in the 
window to the right of the graph. Storing a run allows you to collect additional data (additional runs) 
and to display the results of multiple runs on the same graph. Storing a run is not the same as saving 
the data file to permanent memory; additional details on saving data is covered in the section on sav-
ing data. 

Brief Overview of Displaying Data 
After collecting one or more sets of data, you can use the Graph menu to control how you display 
your data. To view a data set, select the label “Run X” (where X is the number of one of your data 
sets), which is located to the left of the file cabinet icon, and select the run you wish to examine; 
note that you can select any single run or select all runs.  

To create a custom graph, in which you select the runs to display and select the x-axis and y-axis 
ranges, select Graph Options from the Graph menu. Note that you can create up to two graphs 
and that you can choose to include point protectors and to connect the points with lines. To switch 
between the two graphs, select Show Graph from the Graph menu and select either Graph 1 or 
Graph 2, or display both graphs by selecting All Graphs. Note that you can choose to use the full 
screen to view your graphs by selecting the checkbox for Full Width. 

To examine more closely a small region of your data, tap and drag across the region of interest, 
which will highlight the area in grey, and select Zoom In from the Graph menu. You can return to 
the normal display by selecting Zoom Out from the Graph menu. To remove one or more data 
points from the display, tap on the point (and drag if removing more than one point) and select 
Strike Through Data from the Graph menu; to restore the data, select Restore Data from the 
Graph menu.  



Brief Overview of Analyzing Data 
The software includes a variety of useful tools for analyzing your data. To examine individual points, 
tap on the graph to add a cursor that displays the corresponding x-axis and y-axis values in the 
summary window to the right of the graph. To move the cursor, use the left arrow and the right 
arrow buttons at the bottom of the screen. 

The Analyze menu provides a variety of tools for extracting information from your data, four of 
which are useful within in the context of Chem 260.  

• The Tangent tool adds additional functionality to the cursor by reporting the slope at the se-
lected point.  

• The Statistics tool reports the minimum and maximum values, the mean and the standard devi-
ation, and the number of samples within a highlighted region of your data.  

• The Curve Fit tool allows you to fit to your data one of 10 predefined functions, such as a 
quadratic function, an exponential function, and a straight-line to name three. If a section of the 
data is highlighted, then only that data is used; if no data are highlighted, then the function is fit 
to all the data. 

• The Model tool allows you to fit to your data a user-defined mathematical model. 

Brief Overview of Manipulating Data 
At times we need to take data from a run and transform it mathematically. For example, in a kinetics 
experiment we might monitor a change in absorbance as a function of time. To show that the kinet-
ics are first-order, we replot the data on the y-axis as ln(absorbance) and see if the resulting plot is a 
straight-line. To replot the data we first must add a new calculated column. To add the column, se-
lect New Calculated Column from the Table menu on the Table screen. Select the desired equa-
tion and identify, as appropriate the existing columns to use in the calculation and any constant val-
ues. When the calculation is complete, you will see the calculated column in each run and can add 
the column to existing graphs. 

Brief Overview of Saving Data 
In the section on collecting data, we noted that storing a run is not the same as saving your data file. 
To save data to the device’s internal memory, select Save from the File menu and give your file a 
name. You can open the file at later time by selecting Open from the File menu and selecting the 
file’s name. 

Although the LabQuest 2 software allows you to display, analyze, and manipulate your data, it is not 
as versatile as Vernier’s LoggerPro 3 software, which runs on desktop and laptop computers. In ad-
dition, you may wish to use other programs, such as Excel or a statistical analysis program, to ana-
lyze your data. Finally, you will want access to your data at times when the lab is closed and your 
LabQuest 2 device is not available For these reasons you will want to save your data to an external 
location. There are three options for saving your data to an external location: 

• Send it to yourself by email: To send data to yourself by email, select Email from the File menu. 
You can choose to send your data file (sent as .qmbl file that you can open with LoggerPro 3), 
your current active graph (sent as a .pdf file), your data table (sent as a .txt file from which you 
can cut-and-paste data into Excel), or a screenshot (sent as a .png file). Enter your email address 
and select Send. 

• Save it to a USB flash drive: To save the data file to a USB flash drive (as a .qmbl file that you 
can open with LoggerPro 3), connect your flash drive to the USB port on the left side of the de-
vice. Select Save from the File menu and then select the icon for your USB flash drive, which 



will display the drive’s contents. Give the file a name and select Save. You can open this file on 
any computer running LoggerPro 3. 

• Transfer the file to a computer running LoggerPro 3. To transfer a file to another computer, 
first save the file on the LabQuest 2 device. Next, connect the LabQuest 2 to the computer us-
ing a USB cable (note: the connection to the LabQuest 2 is through the mini USB port on the 
right-side of the device’s case, not the large USB port on the left-side of the device’s case). If it is 
not already open, launch LoggerPro 3. From LoggerPro’s File menu, select LabQuest Browser 
and open your data file. Be sure to save the file to your computer using LoggerPro’s File menu. 

Running the LabQuest 2 Using a Laptop Computer and LoggerPro 3 
Although the LabQuest 2 device is a stand-alone device that allows you to collect, display, manipu-
late, and save data, you can use it solely as a hardware interface, operating it using a laptop computer 
running LoggerPro 3. To do this, connect the LabQuest 2 to the computer using a USB cable (note: 
the connection to the LabQuest 2 is through the mini USB port on the right-side of the device’s 
case, not the large USB port on the left-side of the device’s case). The screen on the LabQuest 2 de-
vice will show a double arrow, which indicates that the computer is controlling the device.  

Although the LabQuest 2 software and the LoggerPro 3 software are similar, there are differences in 
the titles of menus. To connect the LabQuest 2 interface, to set up sensors, to calibrate sensors, and 
to set up data collection on LoggerPro 3, use the Experiment menu. To change how data is dis-
played on a graph, right click on the graph to access the Graph menu. To analyze data, use the Ana-
lyze menu, and to manipulate data, use the Data menu. 


